SCRIPT AсtiveCollab

basix

Best member
Verified
#65
Active Collab 7.1.0
Hidden content. You need Log in or Register.
***Hidden content***
Hidden content. You need Log in or Register.
***Hidden content***

How to disable the new update available message on the system setting page?
activecollab/7.1.0/angie/frameworks/environment/handlers/on_system_status.php
line 50 change to this:
PHP:
$status['new_version_available'] = false;
way to completely remove the upgrade notification:
Hidden content. You need Log in or Register.
***Hidden content***
 
Last edited:

pakko

New member
#67
Hi there.
Just did an upgrade from ActiveCollab v6.1.53 to v7.1.0 using "php activecollab-cli.php upgrade --dont-download-latest"
and everthing seems to be ok.
But in the migration log output you see on screen I see this:
OK: Notice: Migration MigrateRemoveSelfhostedOauth1QuickbookIntegration needs to be executed after these migrations: MigrateAddShowQuickbooksOauth2MigrationPointerConfigOption
Anyone know what to do here in this step here?
Any help would be much appreciated

Many thanks in advance.
Cheers,
Pakko
 
#69
Hi there Globe.
After doing succesfully the upgrade the my imap.google.com stopped working "Instance_id property is required"
Did you figure it out yet?
Thanks,
P.
Hey Pakko, not yet. Still reading trough some laravel configurations to see if this is a known bug. Maybe next nulled release will fix this.
 
#70
Hi there Globe.
After doing succesfully the upgrade the my imap.google.com stopped working "Instance_id property is required"
Did you figure it out yet?
Thanks,
P.
I have the same problem like you, but fixed the problem.
Firstly backup your files and database.
Reinstall from 5.13.133 and then upgrade step by step to new version 7.1
 
#71
I have the same problem like you, but fixed the problem.
Firstly backup your files and database.
Reinstall from 5.13.133 and then upgrade step by step to new version 7.1
Hey mymate20, thanks for your reply. Do you installed all Updates manualy from this thread or what path did you take to upgrade?
 
#74
Solution for error "Instance_id property is required".
activecollab/5.6.4/vendor/activecollab/activecollab-jobs/src/Jobs/Job.php
PHP:
/**
* All Active Collab jobs extend this class.
*
* @package ActiveCollab\ActiveCollabJobs\Jobs
*/
abstract class Job extends BaseJob
{
    /**
     * Construct a new Job instance.
     *
     * @param  array|null               $data
     * @throws InvalidArgumentException
     */
    public function __construct(array $data = null)
    {
      parent::__construct($data);
    }

    /**
     * Validate and return instance ID.
     *
     * @return int
     */
    protected function getInstanceId()
    {
/*        if ($instance_id = $this->getData()['instance_id'])*/
{
            if (!is_int($instance_id) and& ctype_digit($instance_id)) {
                $instance_id = (integer) $instance_id;
            }

            if ($instance_id > 0) {
                return $instance_id;
            } else {
                throw new InvalidArgumentException("Value '$instance_id' is not a valid instance ID");
            }
        } /*else {
            throw new InvalidArgumentException('Instance ID not set');
        }*/
    }
}
 
Last edited by a moderator:
#75
I've seen that made a mistake when adding solution for error "Instance_id property is required", so you guys didn't see my last post.

Previous and above methods with commenting code in /vendor/activecollab/activecollab-jobs/src/Jobs/Job.php are just wrong because they are disabling showing exceptions for wrong license format and this method causes futher problems in mail sending, elastic search configuration etc.

THE ONLY GOOD SOLUTION TO SOLVE ERROR "Instance_id property is required" and keep mails, elasticsearch and all features working, very simple, as by default config file license key in config has wrong format by default and you need to change it to right one with "/" and number:
Edit this file: /config/config.php
Change license key from:
PHP:
const LICENSE_KEY = '123456';
To:
PHP:
const LICENSE_KEY = '123456/5';
You can change number after "/" for whatever number you want excluding 1.
 
#76
When I installed the old version like 5.13.133, the license key is 123456, but when I update step by step from V5 to V6, and V6 to V7, now the license key changed to very long. it looks like:
FB23D33XXXXXXXXXXXXXXXXXXXXXXXXXXXX/555522
 
#77
So i've installed 7.1.0 version from scratch yesterday. Not without problems, but here is somekind of guide.

Clean Nulled ActiveCollab 7.1.0 installation guide:
  1. Place your 5.6.16 version in your server and setup your apache\nginx (5.6.16 is a version that nulled with "[email protected]" user. IDK if this topic have it. I've got it from other place)
  2. Open your AC in browser to get errors at \activecollab\5.6.16\angie\functions\general.php file.
  3. Fix first error with replacing curved brackets with square ones (replace {} to [] at lines that is mentioned in error message)
  4. Fix second error by adding "2" at the end of imagecreatefrombmp function. Make sure that you've added "2" at the end of all imagecreatefrombmp functions in that file. I've got 2 of them.
  5. Install AC with instruction.txt file. Make sure that you've installed all requested extensions for php and made a clean DB for active collab.
  6. Activate it, create your user and delete old one.
  7. Put 6.0.50 folder instide \activecollab folder.
  8. Go to your terminal, cd to active collab root folder and update AC with php tasks/activecollab-cli.php upgrade -v --dont-download-latest command.
  9. If you'll get SQL error just coppy SQL script from error message, change varchar(50) to varchar(191) and then execute it manually inside of your DB. You can do it in phpmyadmin or whatever you're using to manage your DBs. Then repeat update command.
  10. Then put 7.1.0 folder instide \activecollab folder and run update command.
  11. Now you should have fully working 7.1.0 version of AC installed on your server. Well done!

Other things that can be usefull:
If you're getting "Failed to save" error while trying to setup Elasticsearch in Active Collab, than you should downgrade Elasticsearch to 6.8.14 version. AC aren't support anything newer that 6.8.14 version. Yes, while testing of elasticsearch in system setting page says that everything "OK" even if you're using latest version of elasticsearch, actually AC doesen't support it. You must use 6.8.14 version or lower. You can read more at the end of this page.
To setup ActiveCollab SSL you should obviously make SSL certificate (you can have one from Let's Encrypt for free) and then change
PHP:
define('ROOT_URL', 'http://example.com/public')
to
PHP:
define('ROOT_URL', 'https://example.com/public')
inside of your config/config.php file.
 
Top